Uploaded image for project: 'PLCrashReporter'
  1. PLCrashReporter
  2. PLCR-539

Fix Simulator libc++ dependency in Xcode 5.x builds

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2, 1.3
    • Fix Version/s: 1.2, 1.3
    • Component/s: Build System
    • Labels:
      None
    • Only Affects (Apple):
      iOS Simulator

      Description

      We rely on -fno-exceptions to avoid creating runtime link dependencies on the C++ stdlib in our static library targets.

      If GCC_ENABLE_CPP_EXCEPTIONS is set to "no" in an Xcode project, iPhoneSimulator.platform does pass -fno-exceptions to the compiler, but also passes -fexceptions, re-enabling the use of exceptions.

      This is caused by broken compiler flag configurations in Xcode's iPhoneSimulator.platform compiler specs; the compiler specs refer to a legacy "GCC_ENABLE_EXCEPTIONS" flag that is no longer set by Xcode.

      This bug has been reported to Apple as rdar://16620815. We'll need to apply the work-around locally until it has been fixed and we no longer support affected Xcode releases (as of this writing, Xcode 5.0 - 5.1).

        Issue Links

          Activity

          Landon Fuller added a comment -

          Fixed, and merged to master and release/plcrashreporter-1.2


            People

            • Assignee:
              Landon Fuller
              Reporter:
              Landon Fuller
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: